Installeer Classic widgets na update WordPress 5.8

5 aug, 2021

WordPress heeft een core plugin uitgebracht met de naam Classic Widgets. Bijdragers Tonya Mork en Andrew Ozz hebben de plugin gemaakt onder het WordPress Contributors-account. Hiermee kunnen eindgebruikers het op blokken gebaseerde widgets-systeem uitschakelen. Ondersteuning wordt verwacht tot 2022 of zo lang als nodig is volgens de beschrijving van de plugin.

Vorige maand werd door een kleine groep kernleads besloten, na een demo, dat WordPress 5.8 verschillende subcomponenten van zijn Full Site Editing-project uitbrengen. FSE omvat verschillende op zichzelf staande onderdelen die gebruikers meer controle geven over het ontwerp en de lay-out van hun sites. Een van die onderdelen is een herziening van het widgetsysteem.

Widgets zullen op een dag een legacy-functie van het platform worden. Ze verdwijnen echter niet snel. Tijdens de overgang van het pre-block-tijdperk van WordPress naar de uiteindelijke integratie van alle subcomponenten van FSE, hebben gebruikers en thema-ontwikkelaars soms kleinere opstapjes nodig. Op blokken gebaseerde widgets bieden gebruikers meer manieren om met blokken te werken buiten het inhoudsgebied van de post, zonder in een volledige op blokken gebaseerde ervaring te duiken.

Dit is de eerste keer dat velen in de grotere WordPress-gebruikersgemeenschap worden blootgesteld aan blokkades in een nieuwe context. De editor die in WordPress 5.0 werd gelanceerd, richtte zich uitsluitend op de inhoud van de post. Het widgetsysteem in 5.8 verandert klassieke zijbalken in blokcontainers.

Kortom, gebruikers kunnen elk blok in elke zijbalk plaatsen.

Dit is een welkome stap bij het overstappen van gebruikers op de lange termijn, vooral degenen die klassieke thema’s gebruiken, wat nog steeds de meerderheid van alle gebruikers is. Er zijn echter gevallen waarin de plug-in Classic Widgets nodig is. De grootste zal zijn:

  • Gebroken thema’s of eigenzinnige output.
  • Gebruikers geven gewoon de voorkeur aan het oude systeem.

Hoe het ook zij, de plug-in handelt de switch af.

Voor degenen die zich afvragen waarom het kern ontwikkelteam er niet voor zorgt dat op blokken gebaseerde widgets met alle thema’s werken, is het omdat de twee systemen niet precies hetzelfde zijn. Bovendien verwerkt elk thema-ontwerp de uitvoer van de zijbalk op zijn eigen manier. Er is geen manier om 100% dekking te garanderen.

classic widgets

 

Veel thema’s zullen helemaal geen problemen hebben. Sommige zijbalken kunnen, afhankelijk van het ontwerp, volledig kapot gaan. Meer waarschijnlijk dan gebroken, kunnen aangepaste zijbalk- en widgetontwerpen er gewoon “uit” aan de voorkant lijken.

Classic Widgets installeren

Classic Widgets heeft geen instellingenscherm of iets om te configureren. Het is een set-it-and-forget-it-plug-in. Het doel is om gebruikers eenvoudig terug te brengen naar het traditionele widgetsysteem waarmee ze vertrouwd zijn.

Als je het nieuwe op blokken gebaseerde widgets-systeem gaat gebruiken, verlies je al jouwwidgetblokken bij het activeren van de plug-in. Er is geen weg terug, dus zorg ervoor dat dit is wat je wilt. De voormalige blokkades zullen niet opnieuw verschijnen als je van gedachten verandert en Classic Widgets deactiveert.

Als je echter traditionele widgets aan de zijbalken van het thema toevoegt terwijl de plug-in actief is, raak je ze niet kwijt. Ze verschijnen nog steeds aan de voor- en achterkant als u de plug-in deactiveert.

0 reacties